[LinuxPPS] refclock_nmea patch
Rodolfo Giometti
giometti at enneenne.com
Tue Oct 23 10:51:39 CEST 2007
On Tue, Oct 23, 2007 at 05:54:43AM +0200, Udo van den Heuvel wrote:
>
> You mean NMEA when you say 'GPS data source'?
> I think both, looking at the code. (where the PPS API interface is started)
But when you talk about /dev/gps0 you point __only__ the GPS data
source, while you talk about /dev/pps0 you point __only__ the PPS data
source. NMEA is represented by both /dev/gps0 __and__ /dev/pps0.
> > The former is correct beacuse /dev/gps0 is _not_ a PPS source, it's a
> > serial line (points to /dev/ttyS0), the latter I don't know. :)
>
> We open a fd on a device, do time_pps_create and when it fails, we open
> the fd on another device, do another time_pps_create...
> So the fd is not saved.
> So how can ntpd use the first device for NMEA and the second for PPS?
I don't know NMEA code but it seems to me you are working inside a
function, is the fd passed to it? If not you have to save fd
somewhere, maybe in up->fd?
> Maybe this can help:
> When is the /dev entry (pps0) created?
> Based on what input?
If you have udev when the pps device is created, otherwise you have to
create it by yourself by using mknod.
> --- org.ntp-4.2.4p2/ntpd/refclock_nmea.c 2006-06-06 22:16:53.000000000 +0200
> +++ ntp-4.2.4p2/ntpd/refclock_nmea.c 2007-10-23 05:52:09.000000000 +0200
> @@ -61,6 +61,7 @@
> # define DEVICE "COM%d:" /* COM 1 - 3 supported */
> #else
> # define DEVICE "/dev/gps%d" /* name of radio device */
> +# define DEVICEPPS "/dev/pps%d" /* name of alternate PPS radio device */
> #endif
> #define SPEED232 B4800 /* uart speed (4800 bps) */
> #define PRECISION (-9) /* precision assumed (about 2 ms) */
> @@ -71,6 +72,7 @@
> #define RANGEGATE 500000 /* range gate (ns) */
>
> #define LENNMEA 75 /* min timecode length */
> +#define LENPPS PPS_MAX_NAME_LEN
>
> /*
> * Tables to compute the ddd of year form icky dd/mm timecode. Viva la
> @@ -231,15 +233,27 @@
> * the assert edge and do not enable the kernel hardpps.
> */
> if (time_pps_create(fd, &up->handle) < 0) {
> - up->handle = 0;
> - msyslog(LOG_ERR,
> - "refclock_nmea: time_pps_create failed: %m");
> - return (1);
> + /* Try the alternate PPS device */
> + (void) sprintf(device, DEVICEPPS, unit);
> + msyslog(LOG_ERR, "refclock_nmea: try alternate PPS device \"%s\"", device);
> + fd = open(device, O_RDWR);
I don't know NMEA code but maybe here you are overriding the GPS data
source file descriptor... if so you should use different variable
(pps_fd?).
Can you please post the whole function you are modifying so I can
understand if the fd should be renamed or not?
> + if (fd < 0)
> + goto pps_error;
> + if (time_pps_create(fd, &up->handle) < 0)
> + goto pps_error;
> }
> + else (void) sprintf(device, DEVICE, unit); /* just rebuild device's name */
> + msyslog(LOG_INFO, "refclock_nmea: found PPS source \"%s\"", device);
> return(nmea_ppsapi(peer, 0, 0));
> #else
> return (1);
> #endif /* HAVE_PPSAPI */
> +
> +pps_error:
> + /* No luck, no PPS unit available! */
> + up->handle = -1;
> + msyslog(LOG_ERR, "refclock_nmea: no PPS devices found at " DEVICE " nor " DEVICEPPS ": %m", unit, unit);
> + return (1);
> }
>
> /*
> @@ -257,8 +271,7 @@
> pp = peer->procptr;
> up = (struct nmeaunit *)pp->unitptr;
> #ifdef HAVE_PPSAPI
> - if (up->handle != 0)
> - time_pps_destroy(up->handle);
> + time_pps_destroy(up->handle);
> #endif /* HAVE_PPSAPI */
> io_closeclock(&pp->io);
> free(up);
> @@ -366,7 +379,7 @@
> /*
> * Convert the timespec nanoseconds field to ntp l_fp units.
> */
> - if (up->handle == 0)
> + if (up->handle == -1)
> return (0);
> timeout.tv_sec = 0;
> timeout.tv_nsec = 0;
Ciao,
Rodolfo
--
GNU/Linux Solutions e-mail: giometti at enneenne.com
Linux Device Driver giometti at gnudd.com
Embedded Systems giometti at linux.it
UNIX programming phone: +39 349 2432127
More information about the LinuxPPS
mailing list